Product List
Incident Report for GlobalTill
Resolved
This incident has been resolved.
Posted Aug 20, 2023 - 23:54 PDT
Monitoring
We have implemented a fix and are monitoring the results.
Posted Aug 16, 2023 - 02:24 PDT
Identified
There is a known issue with some functionality for the product table under the Products > List section. We understand that this may cause temporary inconvenience in managing your product data and are we have our engineering team actively working on resolving this problem as quickly as possible.
Posted Aug 15, 2023 - 15:07 PDT
This incident affected: Core (Admin / Back-end).